portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

gnupg-2.4.7-r1.ebuild (5022B)


      1 # Copyright 1999-2025 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 # Maintainers should:
      7 # 1. Join the "Gentoo" project at https://dev.gnupg.org/project/view/27/
      8 # 2. Subscribe to release tasks like https://dev.gnupg.org/T6159
      9 # (find the one for the current release then subscribe to it +
     10 # any subsequent ones linked within so you're covered for a while.)
     11 
     12 VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/gnupg.asc
     13 # in-source builds are not supported: https://dev.gnupg.org/T6313#166339
     14 inherit flag-o-matic out-of-source multiprocessing systemd toolchain-funcs verify-sig
     15 
     16 MY_P="${P/_/-}"
     17 
     18 DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
     19 HOMEPAGE="https://gnupg.org/"
     20 SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
     21 SRC_URI+=" verify-sig? ( mirror://gnupg/gnupg/${P}.tar.bz2.sig )"
     22 S="${WORKDIR}/${MY_P}"
     23 
     24 LICENSE="GPL-3+"
     25 SLOT="0"
     26 KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
     27 IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl test +tofu tpm tools usb user-socket wks-server"
     28 RESTRICT="!test? ( test )"
     29 REQUIRED_USE="test? ( tofu )"
     30 
     31 # Existence of executables is checked during configuration.
     32 # Note: On each bump, update dep bounds on each version from configure.ac!
     33 DEPEND="
     34 	>=dev-libs/libassuan-2.5.0:=
     35 	>=dev-libs/libgcrypt-1.9.1:=
     36 	>=dev-libs/libgpg-error-1.46
     37 	>=dev-libs/libksba-1.6.3
     38 	>=dev-libs/npth-1.2
     39 	sys-libs/zlib
     40 	bzip2? ( app-arch/bzip2 )
     41 	ldap? ( net-nds/openldap:= )
     42 	readline? ( sys-libs/readline:0= )
     43 	smartcard? ( usb? ( virtual/libusb:1 ) )
     44 	tofu? ( >=dev-db/sqlite-3.27 )
     45 	tpm? ( >=app-crypt/tpm2-tss-2.4.0:= )
     46 	ssl? ( >=net-libs/gnutls-3.2:0= )
     47 "
     48 RDEPEND="
     49 	${DEPEND}
     50 	nls? ( virtual/libintl )
     51 	selinux? ( sec-policy/selinux-gpg )
     52 	wks-server? ( virtual/mta )
     53 "
     54 PDEPEND="
     55 	|| (
     56 		app-crypt/pinentry
     57 		app-crypt/pinentry-dmenu
     58 	)
     59 "
     60 BDEPEND="
     61 	virtual/pkgconfig
     62 	doc? ( sys-apps/texinfo )
     63 	nls? ( sys-devel/gettext )
     64 	verify-sig? ( sec-keys/openpgp-keys-gnupg )
     65 "
     66 
     67 DOCS=(
     68 	ChangeLog NEWS README THANKS TODO VERSION
     69 	doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
     70 )
     71 
     72 PATCHES=(
     73 	"${FILESDIR}"/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch
     74 	"${FILESDIR}"/${PN}-2.4.5-revert-rfc4880bis.patch # bug #926186
     75 )
     76 
     77 src_prepare() {
     78 	default
     79 }
     80 
     81 my_src_configure() {
     82 	# Upstream don't support LTO, bug #854222.
     83 	filter-lto
     84 
     85 	local myconf=(
     86 		$(use_enable bzip2)
     87 		$(use_enable nls)
     88 		$(use_enable smartcard scdaemon)
     89 		$(use_enable ssl gnutls)
     90 		$(use_enable test all-tests)
     91 		$(use_enable test tests)
     92 		$(use_enable tofu)
     93 		$(use_enable tofu keyboxd)
     94 		$(use_enable tofu sqlite)
     95 		$(usex tpm '--with-tss=intel' '--disable-tpm2d')
     96 		$(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver')
     97 		$(use_enable wks-server wks-tools)
     98 		$(use_with ldap)
     99 		$(use_with readline)
    100 
    101 		# Hardcode mailprog to /usr/libexec/sendmail even if it does not exist.
    102 		# As of GnuPG 2.3, the mailprog substitution is used for the binary called
    103 		# by wks-client & wks-server; and if it's autodetected but not not exist at
    104 		# build time, then then 'gpg-wks-client --send' functionality will not
    105 		# work. This has an unwanted side-effect in stage3 builds: there was a
    106 		# [R]DEPEND on virtual/mta, which also brought in virtual/logger, bloating
    107 		# the build where the install guide previously make the user chose the
    108 		# logger & mta early in the install.
    109 		--with-mailprog=/usr/libexec/sendmail
    110 
    111 		--disable-ntbtls
    112 		--enable-gpgsm
    113 		--enable-large-secmem
    114 
    115 		CC_FOR_BUILD="$(tc-getBUILD_CC)"
    116 		GPGRT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpgrt-config"
    117 
    118 		$("${S}/configure" --help | grep -o -- '--without-.*-prefix')
    119 	)
    120 
    121 	if use prefix && use usb; then
    122 		# bug #649598
    123 		append-cppflags -I"${ESYSROOT}/usr/include/libusb-1.0"
    124 	fi
    125 
    126 	if [[ ${CHOST} == *-solaris* ]] ; then
    127 		# https://dev.gnupg.org/T7368
    128 		append-cppflags -D_XOPEN_SOURCE=500
    129 	fi
    130 
    131 	# bug #663142
    132 	if use user-socket; then
    133 		myconf+=( --enable-run-gnupg-user-socket )
    134 	fi
    135 
    136 	# glib fails and picks up clang's internal stdint.h causing weird errors
    137 	tc-is-clang && export gl_cv_absolute_stdint_h="${ESYSROOT}"/usr/include/stdint.h
    138 
    139 	econf "${myconf[@]}"
    140 }
    141 
    142 my_src_compile() {
    143 	default
    144 
    145 	use doc && emake -C doc html
    146 }
    147 
    148 my_src_test() {
    149 	export TESTFLAGS="--parallel=$(makeopts_jobs)"
    150 
    151 	default
    152 }
    153 
    154 my_src_install() {
    155 	emake DESTDIR="${D}" install
    156 
    157 	use tools && dobin tools/{gpgconf,gpgsplit,gpg-check-pattern} tools/make-dns-cert
    158 
    159 	dosym gpg /usr/bin/gpg2
    160 	dosym gpgv /usr/bin/gpgv2
    161 	echo ".so man1/gpg.1" > "${ED}"/usr/share/man/man1/gpg2.1 || die
    162 	echo ".so man1/gpgv.1" > "${ED}"/usr/share/man/man1/gpgv2.1 || die
    163 
    164 	dodir /etc/env.d
    165 	echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >> "${ED}"/etc/env.d/30gnupg || die
    166 
    167 	use doc && dodoc doc/gnupg.html/*
    168 }
    169 
    170 my_src_install_all() {
    171 	einstalldocs
    172 
    173 	use tools && dobin tools/{convert-from-106,mail-signed-keys,lspgpot}
    174 	use doc && dodoc doc/*.png
    175 }