portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

hyx-2021.06.09.ebuild (334B)


      1 EAPI=8
      2 
      3 DESCRIPTION="A minimal Linux console hex editor"
      4 HOMEPAGE="https://yx7.cc/code"
      5 SRC_URI="https://yx7.cc/code/hyx/${P}.tar.xz"
      6 
      7 SLOT=0
      8 IUSE="+static"
      9 
     10 src_configure() {
     11 	default
     12 
     13 	if use static; then
     14 		export CFLAGS="${CFLAGS} -static"
     15 	fi
     16 }
     17 
     18 src_install() {
     19 	emake DESTDIR="${D}"
     20 	into ${EPREFIX}${LOCAL_PREFIX}
     21 		dobin hyx
     22 }