portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

vis-0.8-r99.ebuild (1107B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
      7 
      8 inherit lua-single optfeature
      9 
     10 KEYWORDS="~amd64 ~arm ~riscv ~x86"
     11 
     12 DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor (dependencies only)"
     13 HOMEPAGE="https://github.com/martanne/vis"
     14 SLOT="0"
     15 IUSE="+ncurses +lua selinux static-libs test tre"
     16 REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
     17 
     18 # - Known to also work with NetBSD curses
     19 # lpeg: https://github.com/martanne/vis-test/issues/28
     20 DEPEND="
     21 	dev-libs/libtermkey[static-libs?]
     22 	sys-apps/acl[static-libs?]
     23 	ncurses? ( sys-libs/ncurses:0=[static-libs?] )
     24 	lua? ( ${LUA_DEPS} )
     25 	tre? ( dev-libs/tre )
     26 	test? (
     27 		$(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
     28 		$(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
     29 	)"
     30 RDEPEND="${DEPEND}
     31 	app-eselect/eselect-vi"
     32 
     33 update_symlinks() {
     34 	einfo "Calling eselect vi update --if-unset"
     35 	eselect vi update --if-unset
     36 }
     37 
     38 pkg_postrm() {
     39 	update_symlinks
     40 }
     41 
     42 pkg_postinst() {
     43 	update_symlinks
     44 	optfeature "syntax highlighting support" dev-lua/lpeg
     45 }