portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

vis-0.9-r99.ebuild (778B)


      1 # Copyright 1999-2023 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
      7 
      8 inherit lua-single
      9 
     10 KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
     11 
     12 DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor (dependencies only)"
     13 HOMEPAGE="https://github.com/martanne/vis"
     14 SLOT="0"
     15 IUSE="+ncurses +lua selinux static-libs test tre"
     16 REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
     17 
     18 # - Known to also work with NetBSD curses
     19 # lpeg: https://github.com/martanne/vis-test/issues/28
     20 DEPEND="
     21 	dev-libs/libtermkey
     22 	ncurses? ( sys-libs/ncurses:0= )
     23 	lua? ( ${LUA_DEPS} )
     24 	tre? ( dev-libs/tre )
     25 	test? (
     26 		$(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
     27 		$(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
     28 	)"
     29