portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

ibus-anthy-1.5.16.ebuild (1316B)


      1 # Copyright 1999-2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI="8"
      5 PYTHON_COMPAT=( python3_{9..12} )
      6 
      7 inherit autotools gnome2-utils python-single-r1 xdg
      8 
      9 DESCRIPTION="Japanese Anthy engine for IBus"
     10 HOMEPAGE="https://github.com/ibus/ibus/wiki"
     11 SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
     12 
     13 LICENSE="GPL-2"
     14 SLOT="0"
     15 KEYWORDS="amd64 arm64 ~ppc x86"
     16 IUSE="nls"
     17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
     18 
     19 RDEPEND="${PYTHON_DEPS}
     20 	app-i18n/anthy
     21 	$(python_gen_cond_dep '
     22 		app-i18n/ibus[python(+),${PYTHON_USEDEP}]
     23 		dev-python/pygobject:3[${PYTHON_USEDEP}]
     24 	')
     25 	nls? ( virtual/libintl )"
     26 DEPEND="${RDEPEND}"
     27 BDEPEND="sys-devel/gettext
     28 	virtual/pkgconfig"
     29 
     30 src_prepare() {
     31 	default
     32 	eautoreconf
     33 	gnome2_environment_reset
     34 }
     35 
     36 src_configure() {
     37 	econf \
     38 		$(use_enable nls) \
     39 		--enable-private-png \
     40 		--with-layout=default \
     41 		--with-python=${EPYTHON}
     42 }
     43 
     44 src_test() {
     45 	:
     46 }
     47 
     48 src_install() {
     49 	default
     50 	find "${ED}" -name '*.la' -delete || die
     51 
     52 	python_optimize
     53 }
     54 
     55 pkg_preinst() {
     56 	xdg_pkg_preinst
     57 	gnome2_schemas_savelist
     58 }
     59 
     60 pkg_postinst() {
     61 	xdg_pkg_postinst
     62 	gnome2_schemas_update
     63 
     64 	if ! has_version app-dicts/kasumi; then
     65 		elog "app-dicts/kasumi is not required but probably useful for you."
     66 	fi
     67 }
     68 
     69 pkg_postrm() {
     70 	xdg_pkg_postrm
     71 	gnome2_schemas_update
     72 }