portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

ncmpcpp-0.10.1.ebuild (1648B)


      1 # Copyright 1999-2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit autotools
      7 
      8 DESCRIPTION="Featureful ncurses based MPD client inspired by ncmpc"
      9 HOMEPAGE="
     10 	https://rybczak.net/ncmpcpp/
     11 	https://github.com/ncmpcpp/ncmpcpp/
     12 "
     13 SRC_URI="https://github.com/ncmpcpp/ncmpcpp/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
     14 
     15 LICENSE="GPL-2+"
     16 SLOT="0"
     17 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
     18 IUSE="clock icu outputs taglib visualizer"
     19 
     20 RDEPEND="
     21 	>=media-libs/libmpdclient-2.1
     22 	dev-libs/boost:=[icu?,nls]
     23 	icu? ( dev-libs/icu:= )
     24 	net-misc/curl
     25 	sys-libs/ncurses:=[unicode(+)]
     26 	sys-libs/readline:=
     27 	taglib? ( media-libs/taglib )
     28 	visualizer? ( sci-libs/fftw:3.0= )
     29 "
     30 DEPEND="${RDEPEND}"
     31 BDEPEND="virtual/pkgconfig"
     32 
     33 DOCS=( CHANGELOG.md README.md )
     34 
     35 src_prepare() {
     36 	default
     37 	eautoreconf
     38 
     39 	sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
     40 	sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
     41 }
     42 
     43 src_configure() {
     44 	local myeconfargs=(
     45 		--without-lto # --with-lto only appends -flto. We need more for a dedicated USE flag
     46 		$(use_enable clock)
     47 		$(use_enable outputs)
     48 		$(use_enable visualizer)
     49 		$(use_with taglib)
     50 		$(use_with visualizer fftw)
     51 	)
     52 
     53 	econf "${myeconfargs[@]}"
     54 }
     55 
     56 src_install() {
     57 	default
     58 
     59 	dodoc doc/{bindings,config}
     60 }
     61 
     62 pkg_postinst() {
     63 	echo
     64 	elog "Example configuration files have been installed at"
     65 	elog "${EROOT}/usr/share/doc/${PF}"
     66 	elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
     67 	elog "as user configuration files."
     68 	echo
     69 	if use visualizer; then
     70 		elog "If you want to use the visualizer, mpd needs to be built with fifo USE flag."
     71 		echo
     72 	fi
     73 }