portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

ncmpcpp-0.9.2-r3.ebuild (1542B)


      1 # Copyright 1999-2022 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit autotools flag-o-matic
      7 
      8 DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
      9 HOMEPAGE="https://ncmpcpp.rybczak.net/ https://github.com/ncmpcpp/ncmpcpp"
     10 SRC_URI="https://rybczak.net/ncmpcpp/stable/${P}.tar.bz2"
     11 
     12 LICENSE="GPL-2"
     13 SLOT="0"
     14 KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86"
     15 IUSE="clock icu lto outputs taglib visualizer"
     16 
     17 RDEPEND="
     18 	>=media-libs/libmpdclient-2.1
     19 	dev-libs/boost:=[icu?,nls]
     20 	icu? ( dev-libs/icu:= )
     21 	net-misc/curl
     22 	sys-libs/ncurses:=[unicode(+)]
     23 	sys-libs/readline:=
     24 	taglib? ( media-libs/taglib )
     25 	visualizer? ( sci-libs/fftw:3.0= )
     26 "
     27 DEPEND="${RDEPEND}"
     28 BDEPEND="virtual/pkgconfig"
     29 
     30 PATCHES=(
     31 	"${FILESDIR}/${PN}-taglib-pc.patch"
     32 )
     33 
     34 src_prepare() {
     35 	default
     36 	eautoreconf
     37 
     38 	sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
     39 	sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
     40 }
     41 
     42 src_configure() {
     43 	filter-flags '-flto*'
     44 
     45 	econf \
     46 		$(use_enable clock) \
     47 		$(use_enable outputs) \
     48 		$(use_enable visualizer) \
     49 		$(use_with lto) \
     50 		$(use_with taglib) \
     51 		$(use_with visualizer fftw)
     52 }
     53 
     54 src_install() {
     55 	default
     56 
     57 	dodoc doc/{bindings,config}
     58 }
     59 
     60 pkg_postinst() {
     61 	echo
     62 	elog "Example configuration files have been installed at"
     63 	elog "${EROOT}/usr/share/doc/${PF}"
     64 	elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
     65 	elog "as user configuration files."
     66 	echo
     67 	if use visualizer; then
     68 	elog "If you want to use the visualizer, you need mpd with fifo enabled."
     69 	echo
     70 	fi
     71 }