portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

ncmpcpp-0.9.2_p20221231.ebuild (1620B)


      1 # Copyright 1999-2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit autotools
      7 
      8 NCMPCPP_COMMIT="9f44edf0b1d74da7cefbd498341d59bc52f6043f"
      9 
     10 DESCRIPTION="Featureful ncurses based MPD client inspired by ncmpc"
     11 HOMEPAGE="https://ncmpcpp.rybczak.net/ https://github.com/ncmpcpp/ncmpcpp"
     12 SRC_URI="https://github.com/ncmpcpp/ncmpcpp/archive/${NCMPCPP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
     13 
     14 LICENSE="GPL-2"
     15 SLOT="0"
     16 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc x86"
     17 IUSE="clock icu outputs taglib visualizer"
     18 
     19 RDEPEND="
     20 	dev-libs/boost:=[icu?,nls]
     21 	icu? ( dev-libs/icu:= )
     22 	media-libs/libmpdclient
     23 	net-misc/curl
     24 	sys-libs/ncurses:=[unicode(+)]
     25 	sys-libs/readline:=
     26 	taglib? ( media-libs/taglib )
     27 	visualizer? ( sci-libs/fftw:3.0= )
     28 "
     29 DEPEND="${RDEPEND}"
     30 BDEPEND="virtual/pkgconfig"
     31 
     32 S="${WORKDIR}/${PN}-${NCMPCPP_COMMIT}"
     33 
     34 src_prepare() {
     35 	default
     36 	eautoreconf
     37 
     38 	sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
     39 	sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
     40 }
     41 
     42 src_configure() {
     43 	# --with-lto only appends -flto
     44 	econf \
     45 		$(use_enable clock) \
     46 		$(use_enable outputs) \
     47 		$(use_enable visualizer) \
     48 		--without-lto \
     49 		$(use_with taglib) \
     50 		$(use_with visualizer fftw)
     51 }
     52 
     53 src_install() {
     54 	default
     55 
     56 	dodoc doc/{bindings,config}
     57 }
     58 
     59 pkg_postinst() {
     60 	echo
     61 	elog "Example configuration files have been installed at"
     62 	elog "${EROOT}/usr/share/doc/${PF}"
     63 	elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
     64 	elog "as user configuration files."
     65 	echo
     66 	if use visualizer; then
     67 	elog "If you want to use the visualizer, you need mpd with fifo enabled."
     68 	echo
     69 	fi
     70 }