portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

ncmpcpp-0.9.2_p20240724.ebuild (1714B)


      1 # Copyright 1999-2024 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=8
      5 
      6 inherit autotools
      7 
      8 NCMPCPP_COMMIT="68daf44032784a5b5b74781a9bf3826053eff4a2"
      9 
     10 DESCRIPTION="Featureful ncurses based MPD client inspired by ncmpc"
     11 HOMEPAGE="
     12 	https://rybczak.net/ncmpcpp/
     13 	https://github.com/ncmpcpp/ncmpcpp/
     14 "
     15 SRC_URI="https://github.com/ncmpcpp/ncmpcpp/archive/${NCMPCPP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
     16 S="${WORKDIR}/${PN}-${NCMPCPP_COMMIT}"
     17 
     18 LICENSE="GPL-2+"
     19 SLOT="0"
     20 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc x86"
     21 IUSE="clock icu outputs taglib visualizer"
     22 
     23 RDEPEND="
     24 	>=media-libs/libmpdclient-2.1
     25 	dev-libs/boost:=[icu?,nls]
     26 	icu? ( dev-libs/icu:= )
     27 	net-misc/curl
     28 	sys-libs/ncurses:=[unicode(+)]
     29 	sys-libs/readline:=
     30 	taglib? ( media-libs/taglib )
     31 	visualizer? ( sci-libs/fftw:3.0= )
     32 "
     33 DEPEND="${RDEPEND}"
     34 BDEPEND="virtual/pkgconfig"
     35 
     36 src_prepare() {
     37 	default
     38 	eautoreconf
     39 
     40 	sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
     41 	sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
     42 }
     43 
     44 src_configure() {
     45 	local myeconfargs=(
     46 		--without-lto # --with-lto only appends -flto. We need more for a dedicated USE flag
     47 		$(use_enable clock)
     48 		$(use_enable outputs)
     49 		$(use_enable visualizer)
     50 		$(use_with taglib)
     51 		$(use_with visualizer fftw)
     52 	)
     53 
     54 	econf "${myeconfargs[@]}"
     55 }
     56 
     57 src_install() {
     58 	default
     59 
     60 	dodoc doc/{bindings,config}
     61 }
     62 
     63 pkg_postinst() {
     64 	echo
     65 	elog "Example configuration files have been installed at"
     66 	elog "${EROOT}/usr/share/doc/${PF}"
     67 	elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
     68 	elog "as user configuration files."
     69 	echo
     70 	if use visualizer; then
     71 		elog "If you want to use the visualizer, mpd needs to be built with fifo USE flag."
     72 		echo
     73 	fi
     74 }