portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

opustags-9999.ebuild (412B)


      1 EAPI=7
      2 
      3 inherit git-r3 cmake
      4 
      5 DESCRIPTION="View and edit opus tags"
      6 HOMEPAGE="https://github.com/fmang/opustags"
      7 EGIT_REPO_URI="https://github.com/fmang/opustags.git"
      8 
      9 LICENSE="BSD"
     10 SLOT=0
     11 IUSE="+static" 
     12 
     13 DEPENDS="media-libs/libogg"
     14 
     15 src_configure() {
     16 	default
     17 	
     18 	use static && LDFLAGS="${LDFLAGS} -s -static"
     19 
     20 	local mycmakeargs=(
     21 		-DCMAKE_INSTALL_PREFIX="${EPREFIX}${LOCAL_PREFIX}"
     22 	)
     23 	cmake_src_configure
     24 }