portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

herbe-9999.ebuild (662B)


      1 EAPI=7
      2 inherit git-r3 savedconfig
      3 
      4 DESCRIPTION="Daemon-less notifications without D-Bus"
      5 HOMEPAGE="https://github.com/dudik/herbe"
      6 EGIT_REPO_URI="https://github.com/dudik/herbe.git"
      7 
      8 LICENSE="MIT"
      9 SLOT="0"
     10 IUSE="savedconfig static"
     11 
     12 DEPEND="
     13 	media-libs/fontconfig
     14 	x11-libs/libX11
     15 	x11-libs/libXft
     16 "
     17 
     18 src_prepare() {
     19 	default
     20 
     21 	sed -e '/^CFLAGS/{s:=:+=:}' \
     22 	< Makefile > Makefile.new || die
     23 	mv Makefile.new Makefile
     24 	
     25 	if use static; then
     26 		export CFLAGS="${CFLAGS} -s -static"
     27 		export LDFLAGS="${LDFLAGS} -s -static"
     28 	fi
     29 	
     30 	restore_config config.h
     31 }
     32 
     33 src_install() {
     34 	emake DESTDIR="${D}" PREFIX="${EPREFIX}${LOCAL_PREFIX}" install
     35 
     36 	save_config config.h
     37 }