portage-overlay

personal portage ebuild repository
git clone anongit@rnpnr.xyz:portage-overlay.git
Log | Files | Refs | Feed | README

xbanish-9999.ebuild (504B)


      1 EAPI=8
      2 inherit git-r3
      3 
      4 DESCRIPTION="banish the mouse cursor when typing, show it again when the mouse moves"
      5 HOMEPAGE="https://github.com/jcs/xbanish"
      6 EGIT_REPO_URI="https://github.com/jcs/xbanish.git"
      7 
      8 SLOT="0"
      9 IUSE="static"
     10 
     11 RDEPEND="x11-libs/libX11"
     12 
     13 src_prepare() {
     14 	default
     15 
     16 	sed	-e '/^MANDIR/{s:man:share/man:}' \
     17 		< Makefile > Makefile.new || die
     18 	mv Makefile.new Makefile || die
     19 
     20 	if uses static; then
     21 		export LDFLAGS="${LDFLAGS} -static"
     22 	fi
     23 }
     24 
     25 src_install() {
     26 	emake DESTDIR="${D}" install
     27 }