Commit: 15d1515a4a21ec238ac4774e6f607cd271a6a700
Parent: 92f2741aa066f09223d0272c78bcf791beb3e035
Author: Randy Palamar
Date: Tue, 31 Jan 2023 19:41:32 -0700
sys-devel/tcc: properly support building as a static binary
Diffstat:
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/sys-devel/tcc/tcc-0.9.27.ebuild b/sys-devel/tcc/tcc-0.9.27.ebuild
@@ -10,7 +10,11 @@ SLOT="0"
IUSE="+static"
src_configure() {
- econf --cc=${CC} \
+ if use static; then
+ LDFLAGS="${LDFLAGS} -static"
+ fi
+
+ econf --extra-ldflags="${LDFLAGS}" \
--prefix="${EPREFIX}${LOCAL_PREFIX}" \
--config-musl \
$(use_enable static)