Commit: 83df4c135a61cd29a2fee3e1b8093d94d5edf31d
Parent: e7fec2c4510ab5da969218b815c70e97ba5ffdeb
Author: 0x766F6964
Date: Thu, 24 Oct 2019 21:08:38 -0600
freebsd is no longer in the gentoo tree, remove keywords and dead code
Diffstat:
2 files changed, 5 insertions(+), 14 deletions(-)
diff --git a/app-emulation/qemu/qemu-4.0.0-r50.ebuild b/app-emulation/qemu/qemu-4.0.0-r50.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} = *9999* ]]; then
SRC_URI=""
else
SRC_URI="http://wiki.qemu-project.org/download/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+ KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 ~x86"
fi
DESCRIPTION="QEMU + Kernel-based Virtual Machine userland tools"
@@ -29,7 +29,7 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug doc
+fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
- kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
+ lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
spice ssh static static-user systemtap tci test usb usbredir vde
+vhost-net virgl virtfs +vnc vte xattr xen xfs"
@@ -533,11 +533,6 @@ qemu_src_configure() {
echo "../configure ${conf_opts[*]}"
cd "${builddir}"
../configure "${conf_opts[@]}" || die "configure failed"
-
- # FreeBSD's kernel does not support QEMU assigning/grabbing
- # host USB devices yet
- use kernel_FreeBSD && \
- sed -i -E -e "s|^(HOST_USB=)bsd|\1stub|" "${S}"/config-host.mak
}
src_configure() {
diff --git a/sys-apps/openrc/openrc-0.17.ebuild b/sys-apps/openrc/openrc-0.17.ebuild
@@ -13,15 +13,15 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
else
SRC_URI="https://dev.gentoo.org/~williamh/dist/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
fi
LICENSE="BSD-2"
SLOT="0"
IUSE="audit debug ncurses pam newnet prefix netifrc selinux static-libs
- tools unicode kernel_linux kernel_FreeBSD"
+ tools unicode kernel_linux"
-COMMON_DEPEND="kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-ubin-9.0_rc sys-process/fuser-bsd ) )
+COMMON_DEPEND="
ncurses? ( sys-libs/ncurses:0= )
pam? (
sys-auth/pambase
@@ -45,7 +45,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
!prefix? (
kernel_linux? ( >=sys-apps/sysvinit-2.86-r6 )
- kernel_FreeBSD? ( sys-freebsd/freebsd-sbin )
)
selinux? (
sec-policy/selinux-base-policy
@@ -84,9 +83,6 @@ src_compile() {
if use kernel_linux ; then
MAKE_ARGS="${MAKE_ARGS} OS=Linux"
brand="Linux"
- elif use kernel_FreeBSD ; then
- MAKE_ARGS="${MAKE_ARGS} OS=FreeBSD"
- brand="FreeBSD"
fi
export BRANDING="Gentoo ${brand}"
use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"