Commit: a66e7aaf470ae4740e5132b680f7022716bd358f
Parent: 48f2cbd70403ac7258b41e9dbc6ed393f899d762
Author: opask
Date: Tue, 8 Jan 2019 17:06:02 -0700
make static a use flag in sys-devel/tcc
Diffstat:
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sys-devel/tcc/tcc-0.9.27.ebuild b/sys-devel/tcc/tcc-0.9.27.ebuild
@@ -7,11 +7,13 @@ SRC_URI="http://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
+IUSE="+static"
+
src_configure() {
econf --cc=${CC} \
--prefix="${EPREFIX}${LOCAL_PREFIX}" \
--config-musl \
- --enable-static
+ $(use_enable static)
}
src_install() {