Commit: c13f9b2a92754b14ea83d5adf65c1b75f2c85561
Parent: c63e481082179cf0af61c3e51c58859fb70d52d7
Author: Randy Palamar
Date: Mon, 27 Dec 2021 14:05:47 -0700
fix sys-apps/openrc
Diffstat:
2 files changed, 20 insertions(+), 4 deletions(-)
diff --git a/sys-apps/openrc/files/rc-logger_h_mark_extern_var.patch b/sys-apps/openrc/files/rc-logger_h_mark_extern_var.patch
@@ -0,0 +1,15 @@
+diff --git a/src/rc/rc-logger.h b/src/rc/rc-logger.h
+index 8c0cc2a..1e02f6c 100644
+--- a/src/rc/rc-logger.h
++++ b/src/rc/rc-logger.h
+@@ -26,8 +26,8 @@
+ #ifndef RC_LOGGER_H
+ #define RC_LOGGER_H
+
+-pid_t rc_logger_pid;
+-int rc_logger_tty;
++extern pid_t rc_logger_pid;
++extern int rc_logger_tty;
+ extern bool rc_in_logger;
+
+ void rc_logger_open(const char *runlevel);
diff --git a/sys-apps/openrc/openrc-0.17.ebuild b/sys-apps/openrc/openrc-0.17.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic multilib pam toolchain-funcs
+inherit eutils flag-o-matic multilib pam usr-ldscript toolchain-funcs
DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
@@ -54,6 +54,8 @@ RDEPEND="${COMMON_DEPEND}
PDEPEND="netifrc? ( net-misc/netifrc )"
+PATCHES=("${FILESDIR}"/rc-logger_h_mark_extern_var.patch)
+
src_prepare() {
sed -i 's:0444:0644:' mk/sys.mk || die
@@ -62,8 +64,7 @@ src_prepare() {
sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/gitver.mk || die
fi
- # Allow user patches to be applied without modifying the ebuild
- epatch_user
+ default
}
src_compile() {