Commit: ca324219b577dc2f95d024f037b55abf907a48e6
Parent: e6acae84583f215d1cf5fcb5dae885974efd3860
Author: opask
Date: Wed, 9 Jan 2019 06:41:45 -0700
and fixed virtual/ffmpeg
Diffstat:
2 files changed, 23 insertions(+), 0 deletions(-)
diff --git a/virtual/ffmpeg/Manifest b/virtual/ffmpeg/Manifest
@@ -0,0 +1 @@
+EBUILD ffmpeg-9-r2.ebuild 1007 SHA256 beaf33ee36315e9647ec9589f522be83f21ec953fa8412c5fd3a723245047340 SHA512 400c03e547526db6a2cdcc70b1fd5719a3649bf9343a4d70c056747d359d99793261a15151649387ae502dd5146c477b53e0f95612263e10ed404855e67558fe WHIRLPOOL b2adde48dbd0af3824cc523ff570d8e3f425fae0e6fd9ee609a00d518b001c0bc93aa0ce7fdf54fa2793749e86385fe1e6c2de5495c883c882d47f389423351e
diff --git a/virtual/ffmpeg/ffmpeg-9-r2.ebuild b/virtual/ffmpeg/ffmpeg-9-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Virtual package for FFmpeg executable implementation"
+
+# Please note that this virtual is only suited for packages that call
+# ffmpeg/avconv or one of the remaining executables. If your package
+# links to one of the libraries, you need to use the following
+# dependency instead (adding IUSE=libav):
+# libav? ( media-video/libav:0= )
+# !libav? ( media-video/ffmpeg:0= )
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k libav mp3 opus sdl theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ libav? ( >=media-video/libav-9.12[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+ !libav? ( >=media-video/ffmpeg-1.2.6-r1:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+"