Commit: d85741b4e8afc5f931bb3e49270bfa12f5e40221
Parent: 83df4c135a61cd29a2fee3e1b8093d94d5edf31d
Author: 0x766F6964
Date: Fri, 1 Nov 2019 19:52:20 -0600
add back removed icu USE flag for ncmpcpp
removing the flag was not the correct fix for:
https://bugs.gentoo.org/show_bug.cgi?id=686714
ncmpcpp links and works just fine if libicu is not present
Diffstat:
2 files changed, 66 insertions(+), 0 deletions(-)
diff --git a/media-sound/ncmpcpp/Manifest b/media-sound/ncmpcpp/Manifest
@@ -0,0 +1 @@
+DIST ncmpcpp-0.8.2.tar.bz2 465713 BLAKE2B 0d07477b3473e1ac7362175cef4bfb085ebdb4c8b1e77f7bb68d8bf4c645fdcccd067d12e2080a740ade18c57dd055f270d2e50096f0ad3afaa40175e19259cf SHA512 9384edd162f40af23e4f26f437356520f117e4e2ab513ed3de132d2f11e597082d1cb7f0dd3696660d0c9bb85ad03e31fb921c97a11c7b28b32c5907fdbb8e8f
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.8.2-r1.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.8.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+HOMEPAGE="https://rybczak.net/ncmpcpp/"
+SRC_URI="${HOMEPAGE}stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86"
+IUSE="clock icu outputs taglib visualizer"
+
+RDEPEND="
+ !dev-libs/boost:0/1.57.0
+ >=media-libs/libmpdclient-2.1
+ dev-libs/boost:=[icu?,nls,threads]
+ net-misc/curl
+ sys-libs/ncurses:=
+ sys-libs/readline:*
+ icu? ( dev-libs/icu:= )
+ taglib? ( media-libs/taglib )
+ visualizer? ( sci-libs/fftw:3.0= )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
+ sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable clock) \
+ $(use_enable outputs) \
+ $(use_enable visualizer) \
+ $(use_with taglib) \
+ $(use_with visualizer fftw) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ dodoc doc/{bindings,config}
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}/usr/share/doc/${PF}"
+ elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
+ elog "as user configuration files."
+ echo
+ if use visualizer; then
+ elog "If you want to use the visualizer, you need mpd with fifo enabled."
+ echo
+ fi
+}